Companyweb Broken on SBS2008 after WSS3.0 SP2

A customer of mine recently had a problem when their companyweb stopped working. So I started to look into application event logs, services running etc.. and I discovered that a windows update (Service Pack 2 for WSS3.0) did not install correctly. It didnt finish installing and was only part installed.

Now this one absolutely broke my heart and I am not alone on this from my research on the web. So throughout my searches on the web I cam across this article from the SBS Team Blog.And another one from technet . But the simple fix is to download WSS SP2 and manually extract the contents using this command “wssv3sp2-kb953338-x64-fullfile-en-us.exe /extract:c:\extract” and then manually install each component. Now you will think the installation of each package is freezing as they are quite small in size the biggest component being 25mb but leave them alone to finish their installation, restart your server.

Make sure the bindings are correct in IIS Manager on the SBS Sharepoint site and voila your back up and running.

This took me a lot longer than I would have preferred to sort out but there you go. A Microsoft Update that breaks things if not installed correctly with no easy way to roll back.The update also changes Sharepoint authentication to kerbeos instead of NTLM.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s